Actualizar para a mais recente versão

Suporte à dúvidas gerais relacionadas ao phpBB.
Zermatt
Novato
Novato
Mensagens: 14
Registrado em: 05 Fev 2008, 18:34
Contact:

Actualizar para a mais recente versão

Mensagem por Zermatt »

Olá

Tenho um fórum que esteve inactivo desde 2015. Agora queria reactiva-lo mas a versão é a 3.0.12. Como faço para actualizar para a versão mais recente?

Muito obrigado

ImagemImage5 by José Monteiro, no Flickr

Avatar do usuário
_Vinny_
Administrador
Administrador
Mensagens: 5848
Registrado em: 03 Set 2009, 21:59
Nome Real: Marcus Vinicius
Localização: Macapá, AP - Brasil
Contact:

Re: Actualizar para a mais recente versão

Mensagem por _Vinny_ »

Antes de tudo, faça um backup completo, dos arquivos e banco de dados.

Prosseguindo, exclua os arquivos com exceção do arquivo config.php e dos seguintes diretórios:
  • /images/
  • /files/
  • /store/
Baixe a versão mais recente e faça o upload dos arquivos para onde estão os arquivos do seu forum, mas não substitua o arquivo config.php. Assim que enviar tudo, visite o seguinte URL com o dominio do seu site: www.example.com/install/, clique na aba UPDATE ou ATUALIZAR e siga as instruções.
Tradução Português Brasileiro: https://www.phpbb.com/customise/db/tran ... ortuguese/

Precisa de serviços phpBB? Me mande um mensagem privada!

Zermatt
Novato
Novato
Mensagens: 14
Registrado em: 05 Fev 2008, 18:34
Contact:

Re: Actualizar para a mais recente versão

Mensagem por Zermatt »

Vou experimentar. muito obrigado

Zermatt
Novato
Novato
Mensagens: 14
Registrado em: 05 Fev 2008, 18:34
Contact:

Re: Actualizar para a mais recente versão

Mensagem por Zermatt »

Mais uma vez o meu muito obrigado pela ajuda. Já dá, apenas surgiu um "problema". Este:

ImagemImage2 by José Monteiro, no Flickr

Também dá estes "erros"

ImagemImage3 by José Monteiro, no Flickr

ImagemImage4 by José Monteiro, no Flickr

Aqui

ImagemImage5 by José Monteiro, no Flickr

quando carrego em Extensões aparece este erro

ImagemImage6 by José Monteiro, no Flickr

E quando carrego aqui

ImagemImage7 by José Monteiro, no Flickr

aparece

ImagemImage8 by José Monteiro, no Flickr

Suponho eu que tenha a ver com mods que eu tinha instalado anteriormente e que agora não tenho nenhum.

Mais uma vez o meu sincero bem-haja

henrique.seven2011
Moderador
Moderador
Mensagens: 966
Registrado em: 23 Mar 2012, 13:50
Nome Real: Saulo Henrique

Re: Actualizar para a mais recente versão

Mensagem por henrique.seven2011 »

Para que faça a atualização do 3.0 para versões superiores é preciso antes remover todos os mods. A partir do 3.1 não existe mais mods, mas extensões que vc sobe para o ficheiro "ext". Caso tenha feito o backup antes de atualizar, suba o backup e tenta atualizar novamente, dessa vez removendo os mods.
Lembre-se de baixar a tradução referente a versão que vc atualizou e subir.
Cloud de Verdade?! Recomendo: Vultr, DigitalOcean e LetsCloud | Freelancer a disposição!

Zermatt
Novato
Novato
Mensagens: 14
Registrado em: 05 Fev 2008, 18:34
Contact:

Re: Actualizar para a mais recente versão

Mensagem por Zermatt »

henrique.seven2011 escreveu:
06 Fev 2021, 15:09
Para que faça a atualização do 3.0 para versões superiores é preciso antes remover todos os mods. A partir do 3.1 não existe mais mods, mas extensões que vc sobe para o ficheiro "ext". Caso tenha feito o backup antes de atualizar, suba o backup e tenta atualizar novamente, dessa vez removendo os mods.
Lembre-se de baixar a tradução referente a versão que vc atualizou e subir.
Remover os mods implica inverter o que fiz nos ficheiros, certo? Tipo remover linhas e tabelas que foram adicionadas por altura da instalação. certo?

henrique.seven2011
Moderador
Moderador
Mensagens: 966
Registrado em: 23 Mar 2012, 13:50
Nome Real: Saulo Henrique

Re: Actualizar para a mais recente versão

Mensagem por henrique.seven2011 »

Zermatt escreveu:
06 Fev 2021, 15:57
henrique.seven2011 escreveu:
06 Fev 2021, 15:09
Para que faça a atualização do 3.0 para versões superiores é preciso antes remover todos os mods. A partir do 3.1 não existe mais mods, mas extensões que vc sobe para o ficheiro "ext". Caso tenha feito o backup antes de atualizar, suba o backup e tenta atualizar novamente, dessa vez removendo os mods.
Lembre-se de baixar a tradução referente a versão que vc atualizou e subir.
Remover os mods implica inverter o que fiz nos ficheiros, certo? Tipo remover linhas e tabelas que foram adicionadas por altura da instalação. certo?
Sim, todo esse trabalho.
Cloud de Verdade?! Recomendo: Vultr, DigitalOcean e LetsCloud | Freelancer a disposição!

Zermatt
Novato
Novato
Mensagens: 14
Registrado em: 05 Fev 2008, 18:34
Contact:

Re: Actualizar para a mais recente versão

Mensagem por Zermatt »

henrique.seven2011 escreveu:Sim, todo esse trabalho.
Tchiii, tinha um montão de mods instalados, vale mais a pena desistir até porque já nem tenho os mods comigo, sei quais eram porque tenho uma lista dos que tinha instalado. deixo assim. Pensei que desse para restaurar a partir de apenas manter o mais importante importado da base de dados, tipo utilizadores, mensagens, rank, etc, etc, etc,.

Bom, como mesmo assim dá para consultar apesar de alguns erros vou deixar.

Muito obrigado pelo esclarecimento e ajuda.

henrique.seven2011
Moderador
Moderador
Mensagens: 966
Registrado em: 23 Mar 2012, 13:50
Nome Real: Saulo Henrique

Re: Actualizar para a mais recente versão

Mensagem por henrique.seven2011 »

Suba seu backup e tenta novamente seguindo: https://www.phpbb.com/support/docs/en/3 ... /upgrade3/
Cloud de Verdade?! Recomendo: Vultr, DigitalOcean e LetsCloud | Freelancer a disposição!

Zermatt
Novato
Novato
Mensagens: 14
Registrado em: 05 Fev 2008, 18:34
Contact:

Re: Actualizar para a mais recente versão

Mensagem por Zermatt »

Vou tentar, obrigado

Responder