Erro ao atualizar a versão do PHP

Suporte à dúvidas gerais relacionadas ao phpBB.
Leothompson
Novato
Novato
Mensagens: 3
Registrado em: 10 Jan 2024, 20:01

Erro ao atualizar a versão do PHP

Mensagem por Leothompson »

Olá pessoal, espero que estejam bem!

Meu forum esta hospedado na Hostgator e quando altero a versao do PHP 8.0 ou superior ele apresenta o seguinte erro;

Fatal error: Uncaught TypeError: mysqli_data_seek(): Argument #2 ($offset) must be of type int, mysqli_result given in /home1/dnasi894/ServiceSystem/forum/phpbb/db/driver/mysqli.php:290 Stack trace: #0 /home1/dnasi894/ServiceSystem/forum/phpbb/db/driver/mysqli.php(290): mysqli_data_seek(Object(mysqli_result), Object(mysqli_result)) #1 /home1/dnasi894/ServiceSystem/forum/phpbb/db/driver/driver.php(381): phpbb\db\driver\mysqli->sql_rowseek(Object(mysqli_result), Object(mysqli_result)) #2 /home1/dnasi894/ServiceSystem/forum/phpbb/db/driver/factory.php(297): phpbb\db\driver\driver->sql_fetchfield('topic_count', Object(mysqli_result), Object(mysqli_result)) #3 /home1/dnasi894/ServiceSystem/forum/ext/paybas/recenttopics/core/recenttopics.php(475): phpbb\db\driver\factory->sql_fetchfield('topic_count', Object(mysqli_result)) #4 /home1/dnasi894/ServiceSystem/forum/ext/paybas/recenttopics/core/recenttopics.php(330): paybas\recenttopics\core\recenttopics->gettopiclist() #5 /home1/dnasi894/ServiceSystem/forum/ext/paybas/recenttopics/event/listener.php(71): paybas\recenttopics\core\recenttopics->display_recent_topics() #6 /home1/dnasi894/ServiceSystem/forum/vendor/symfony/event-dispatcher/EventDispatcher.php(214): paybas\recenttopics\event\listener->display_rt(Object(phpbb\event\data), 'core.index_modi...', Object(phpbb\event\dispatcher)) #7 /home1/dnasi894/ServiceSystem/forum/vendor/symfony/event-dispatcher/EventDispatcher.php(44): Symfony\Component\EventDispatcher\EventDispatcher->doDispatch(Array, 'core.index_modi...', Object(phpbb\event\data)) #8 /home1/dnasi894/ServiceSystem/forum/phpbb/event/dispatcher.php(62): Symfony\Component\EventDispatcher\EventDispatcher->dispatch('core.index_modi...', Object(phpbb\event\data)) #9 /home1/dnasi894/ServiceSystem/forum/phpbb/event/dispatcher.php(46): phpbb\event\dispatcher->dispatch('core.index_modi...', Object(phpbb\event\data)) #10 /home1/dnasi894/ServiceSystem/forum/index.php(245): phpbb\event\dispatcher->trigger_event('core.index_modi...', Array) #11 {main} thrown in /home1/dnasi894/ServiceSystem/forum/phpbb/db/driver/mysqli.php on line 290
So consigo rodar o forum na versao do PHP 7.4 para baixo
Estou usando a versao atual do forum 3.3.11
Captura de tela 2024-01-10 200608.png
Agradeço desde ajuda de vocês.
Você não está autorizado a ver ou baixar esse anexo.
Avatar do usuário
_Vinny_
Administrador
Administrador
Mensagens: 5922
Registrado em: 03 Set 2009, 21:59
Contact:

Re: Erro ao atualizar a versão do PHP

Mensagem por _Vinny_ »

Pela mensagem de erro, a extensão Recent Topics não é compatível com PHP 7.4 superior.
Tradução Português Brasileiro: https://www.phpbb.com/customise/db/tran ... ortuguese/

Precisa de serviços phpBB? Me mande um mensagem privada!
Leothompson
Novato
Novato
Mensagens: 3
Registrado em: 10 Jan 2024, 20:01

Re: Erro ao atualizar a versão do PHP

Mensagem por Leothompson »

_Vinny_ escreveu: 11 Jan 2024, 12:41 Pela mensagem de erro, a extensão Recent Topics não é compatível com PHP 7.4 superior.
Obrigado por responder _Vinny_

Vou testar desabilitar hoje no fim do dia para testar.
Avatar do usuário
_Vinny_
Administrador
Administrador
Mensagens: 5922
Registrado em: 03 Set 2009, 21:59
Contact:

Re: Erro ao atualizar a versão do PHP

Mensagem por _Vinny_ »

Verifica se está com a versão mais recente da extensão: https://www.phpbb.com/community/db/exte ... _topics_2/
Tradução Português Brasileiro: https://www.phpbb.com/customise/db/tran ... ortuguese/

Precisa de serviços phpBB? Me mande um mensagem privada!
Leothompson
Novato
Novato
Mensagens: 3
Registrado em: 10 Jan 2024, 20:01

Re: Erro ao atualizar a versão do PHP

Mensagem por Leothompson »

_Vinny_ escreveu: 11 Jan 2024, 18:08 Verifica se está com a versão mais recente da extensão: https://www.phpbb.com/community/db/exte ... _topics_2/
_Vinny_
Realmente era a versão do recente topicos! baixei a ultima versão que justamente da suporte para versao >=8 do PHP
Obrigado mais uma vez pela ajuda!!
Avatar do usuário
_Vinny_
Administrador
Administrador
Mensagens: 5922
Registrado em: 03 Set 2009, 21:59
Contact:

Re: Erro ao atualizar a versão do PHP

Mensagem por _Vinny_ »

De nada =)
Tradução Português Brasileiro: https://www.phpbb.com/customise/db/tran ... ortuguese/

Precisa de serviços phpBB? Me mande um mensagem privada!
Responder