Suporte à dúvidas gerais relacionadas ao phpBB.
  • Avatar do usuário
  • Avatar do usuário
  • Avatar do usuário
#297409
Olá pessoal,

Sou novo aqui e intermediário no Ubuntu.

Tenho um raspberry onde mantenho um fórum na minha intranet apenas para registro de tarefas de trabalho.

Ocorre que estou tentando instalar outro fórum, em outra máquina e aparece esse erro.
PHP XML/DOM support
In order for phpBB to function correctly, the PHP XML/DOM extension needs to be available.
A versão do php instalada é a 7.3.8 e a do fórum phpBB é a 3.2.7

Busquei informações em vários fóruns e não encontrei uma solução.

Alguém aqui poderia me auxiliar no problema?

Desde já fico agradecido.

Segue uma imagem da tela também pra ilustrar melhor.
Captura de Tela 2019-08-09 às 22.15.47.png
Você não está autorizado a ver ou baixar esse anexo.
Editado pela última vez por Tavinho_lkpk em 12 Ago 2019, 22:12, em um total de 2 vezes.
Avatar do usuário
By Tavinho_lkpk
#297413
Veja este topico https://www.phpbb.com/community/viewtopic.php?t=2495546
Esse foi um dos primeiros que eu tentei, infelizmente sem muito sucesso. :/
Tente ativar ou instalação a extensão XML/DOM do PHP.
Tentei já instalra vários pacotes, até mesmo um downgrade do PHP, mas em algum determinado momento ele simplesmente retorna com o 7.3.8 para a minha máquina.

Se puder me esclarecer um pouco melhor como eu poderia ativar ou instalar eu ficaria grato, pois talvez, eu tenha feito de outra maneira que você está sugerindo.


Obs.: Agradeço a disposição dos colegas em me ajudar.
#297417
Bom pessoal, consegui resolver de uma forma relativamente simples.

Primeiro, selecionei para ser usado como padrão o php7.1 com o comando abaixo
Código: Selecionar todos
update-alternatives --config php
Captura de Tela 2019-08-12 às 11.43.39.png
Após isso, fiz a instalação dos pacotes XML e DOM no php7.1 com os seguintes comandos.
Código: Selecionar todos
apt-get install php7.1-xml -y
Código: Selecionar todos
apt-get install php7.1-dom -y
E pra finalizar, reiniciei o Apache2
Código: Selecionar todos
systemctl restart apache2
Atualizei o browser, e pronto, problema resolvido.
Captura de Tela 2019-08-12 às 11.46.07.png
Espero poder ajudar quem vier a ter esse tipo de problema.

Aproveito para agradecer aos colegas que me ajudaram.
Você não está autorizado a ver ou baixar esse anexo.
_Vinny_ liked this

Que eu saiba não tem

Eu gostava muito deste aqui https://www.coffeecup.[…]

É a mesma coisa de sempre só que atu[…]

Aqui no Brasil acho que anda fraco mas fora esta b[…]