Suporte à dúvidas gerais relacionadas ao phpBB.
  • Avatar do usuário
  • Avatar do usuário
#297381
Pessoal,

Minha historia triste, o nosso fórum estava bastante desatualizado, ainda na versão 3.0.12.

Resolvi seguir os passos do site phpbb para efetuar a atualização para a versão mais atual.

Basicamente :
  • fazer backup
  • Desinstalar todos os Mods
  • retornar o prosilver como tema padrão
  • desinstalar todos os idiomas, exceto Inglês britânico
  • Apagar todos os arquivos exceto config.php
  • apagar todas as pastas, exceto : Images, Files e Store
  • copiar todos os arquivos da versão cheia 3.2.7, exceto o arquivo config.php e as pastas acima
  • entrar em seusite.com.br/install
  • clicar na aba Update
Ai ele apresentava erro de falta de acesso a escrita na pasta "cache".... :(

O nosso provedor é a locaweb, utilizamos o serviço windows. tentei via FTP dar permissão total (777) a pasta, mas não funcionou.

Não sei ao certo se o problema é com um servidor windows da locaweb, mas como o tempo foi passando, resolvi abortar o processo de atualização, e retornar o backup do site.

Agora o site não entra no ar.. aparece a mensagem General Error - Could not get style data :(

Pelo que pesquisei, pode ser um problema de acesso a pasta "cache"... conversando com o suporte da locaweb, eles não souberam responder o porque o site funcionava antes e agora não funciona mais.. embora eu ache que apos excluir as pastas e recriar eles, tenham perdido algum atributo importante.... :/

O fórum em questão é o www.teneclub.com.br, se alguém souber de alguma dica, fico grato!

abrs.

PS: minha primeira mensagem aqui..! :)
Fonte : https://www.phpbb.com/support/docs/en/3 ... /upgrade3/
Editado pela última vez por viniciuspc em 27 Jul 2019, 11:44, em um total de 1 vez.
#297384
Obrigado lucas!,

Fiz isso, a mensagem mudou para

Fatal: ./cache/ is NOT writable.

Mas ao confirmar os atributos da sub-pasta cache, ele esta com acesso total "777" :(

Vou ver com o suporte da locaweb se eu posso mudar o servidor do meu plano, do Windows para Linux! tenho certeza que é algo no servidor windows deles!

[]´s
#297386
Pessoal,

O problema foi resolvido.

Conforme havia comentado, estávamos utilizando o servidor Windows, e ao deletar as pastas (cache por exemplo), alguma permissão se perdeu.

Mesmo atribuindo 777 as pastas, o problema persistia. Acredito que seja algo mais ligado ao servidor, com todas as pessoas do suporte da locaweb que eu conversei, apenas uma parecia entender o meu problema! a pessoa me orientou a alterar o servidor para Linux, pois esse é o mais indicado para PHP, fizemos isso, e após um longo processo de mudança (principalmente do banco de dados), consegui atualizar a versao do PHPBB!

Minha dica para quem está usando um servidor Windows e pretende atualizar o PHPBB : não delete as pastas! renomeias! :)

grato a todos!

Que eu saiba não tem

Eu gostava muito deste aqui https://www.coffeecup.[…]

É a mesma coisa de sempre só que atu[…]

Aqui no Brasil acho que anda fraco mas fora esta b[…]