Problema para atualizar 3.2.4 (RESOLVIDO)

Suporte à dúvidas gerais relacionadas ao phpBB.
Avatar do usuário
fabriziopr
Novato
Novato
Mensagens: 29
Registrado em: 15 Jul 2016, 15:47

Problema para atualizar 3.2.4 (RESOLVIDO)

Mensagem por fabriziopr » 21 Nov 2018, 13:12

Após atualização consigo logar porem ao clicar em algum tópico me retorna o erro Fatal error: Call to undefined method bbcode::bbcode() in /home/flyfi697/public_html/novo2/includes/functions_content.php on line 630

Tentei fazer uma instalação limpa usando apenas o banco ja atualizado para esta versão porém o erro permanece.
Editado pela última vez por fabriziopr em 22 Nov 2018, 12:35, em um total de 1 vez.

Avatar do usuário
Chico Gois
Administrador
Administrador
Mensagens: 3428
Registrado em: 03 Jul 2004, 03:53
Nome Real: Chico Gois
Localização: São Paulo - Capital
Contacto:

Re: Problema para atualizar 3.2.4

Mensagem por Chico Gois » 21 Nov 2018, 17:25

Parece ser um erro recorrente no phpBB.com
Atenciosamente,

Chico Gois
Download da tradução: CLIQUE AQUI
Não envie MP pedindo ajuda, utilize o fórum
:: Mundo phpBB ::

Avatar do usuário
Chico Gois
Administrador
Administrador
Mensagens: 3428
Registrado em: 03 Jul 2004, 03:53
Nome Real: Chico Gois
Localização: São Paulo - Capital
Contacto:

Re: Problema para atualizar 3.2.4

Mensagem por Chico Gois » 21 Nov 2018, 19:17

Veja a versão do php que está rodando na sua hospedagem
Atenciosamente,

Chico Gois
Download da tradução: CLIQUE AQUI
Não envie MP pedindo ajuda, utilize o fórum
:: Mundo phpBB ::

Avatar do usuário
fabriziopr
Novato
Novato
Mensagens: 29
Registrado em: 15 Jul 2016, 15:47

Re: Problema para atualizar 3.2.4

Mensagem por fabriziopr » 22 Nov 2018, 07:58

Chico Gois escreveu:
21 Nov 2018, 19:17
Veja a versão do php que está rodando na sua hospedagem
Servidor de base de dados
Servidor: Localhost via UNIX socket
Tipo de servidor: Percona Server
Versão do servidor: 5.6.41-84.1 - Percona Server (GPL), Release 84.1, Revision b308619
Versão do protocolo: 10
Utilizador: flyfi697@localhost
Conjunto de caracteres do servidor: UTF-8 Unicode (utf8)
Servidor web
cpsrvd 11.70.0.61
Versão do cliente de base de dados: libmysql - 5.1.73
Extensão de PHP: mysqliDocumentação curlDocumentação mbstringDocumentação
versão do PHP: 5.6.30
phpMyAdmin
Informação da versão: 4.7.7
Documentação
Página Oficial do phpMyAdmin
Contributo
Obter suporte
Lista de alterações
Licença

Sera que seria este o problema?

Avatar do usuário
fabriziopr
Novato
Novato
Mensagens: 29
Registrado em: 15 Jul 2016, 15:47

Re: Problema para atualizar 3.2.4

Mensagem por fabriziopr » 22 Nov 2018, 08:06

tentei alterar do 5.6 para o 7.1...
ja no index do forum apresenta o seguinte erro:
General Error
SQL ERROR [ mysql4 ]

mysql_connect function does not exist, is mysql extension installed? []

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.

Avatar do usuário
fabriziopr
Novato
Novato
Mensagens: 29
Registrado em: 15 Jul 2016, 15:47

Re: Problema para atualizar 3.2.4

Mensagem por fabriziopr » 22 Nov 2018, 09:01

Alterei a configuração no arquivo config.php alterei para mysqli voltou a funcionar o index.. porem ao tentar acessar um topico o erro permanece o mesmo
Fatal error: Uncaught Error: Call to undefined method bbcode::bbcode() in /home/flyfi697/public_html/novo2/includes/functions_content.php:630 Stack trace: #0 /home/flyfi697/public_html/novo2/viewtopic.php(1718): generate_text_for_display('NOME : Thomas M...', '19enwq6w', 'Qg==', 3, true) #1 {main} thrown in /home/flyfi697/public_html/novo2/includes/functions_content.php on line 630

Avatar do usuário
fabriziopr
Novato
Novato
Mensagens: 29
Registrado em: 15 Jul 2016, 15:47

Re: Problema para atualizar 3.2.4

Mensagem por fabriziopr » 22 Nov 2018, 10:20

Pelo que notei é um bug da versão 3.2.4 que sera corrigido na versão 3.2.5;
Ja disponibilizaram os dois arquivos de correção no GITHUB são eles functions_content.php e bbcode.php.
aparentemente resolveu... apenas esta aparecendo alguns warnings
<[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4564: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/bbcode.php:1)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4564: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/bbcode.php:1)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4564: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/bbcode.php:1)
Mas creio que não seja nada demais
Não consegui anexar os arquivos aqui... caso alguem esteja com o mesmo problema envie MP ou deixe o email que eu envio estes dois arquivos...

Avatar do usuário
fabriziopr
Novato
Novato
Mensagens: 29
Registrado em: 15 Jul 2016, 15:47

Re: Problema para atualizar 3.2.4

Mensagem por fabriziopr » 22 Nov 2018, 12:35

Referente aos warnings era a questão da formatação do arquivo bbcode.php alterei para UTF-8 usando o notepadd++ e resolveu o problema.

Responder