Página 2 de 3

Re: Erro ao enviar mensagens

Enviado: 30 Jan 2018, 15:56
por Vin
Eu estava editando uma mensagem no meu fórum e o mesmo erro apareceu lá no topo da tela, porém continuo conseguindo mexer em tudo normalmente, então não é só quando se usa o bbcode que especifiquei.

Re: Erro ao enviar mensagens

Enviado: 31 Jan 2018, 02:05
por Chico Gois
Fiz um teste aqui com este bbcode e funciona normal

Re: Erro ao enviar mensagens

Enviado: 31 Jan 2018, 02:09
por Chico Gois
Versão do phpBB?

Re: Erro ao enviar mensagens

Enviado: 01 Fev 2018, 13:08
por Vin
Chico Gois escreveu:
31 Jan 2018, 02:09
Versão do phpBB?
3.1.12

Re: Erro ao enviar mensagens

Enviado: 01 Fev 2018, 17:33
por Chico Gois
Está desatualizado, porque não atualiza?

Re: Erro ao enviar mensagens

Enviado: 04 Fev 2018, 16:10
por Vin
Chico Gois escreveu:
01 Fev 2018, 17:33
Está desatualizado, porque não atualiza?
Eu não atualizo para a 3.2 pois tem alguns bbcodes que não funciona, e no meu ACP não diz que há uma versão da 3.1 disponível..

Re: Erro ao enviar mensagens

Enviado: 04 Fev 2018, 18:25
por Vin
Eu baixei o phpBB novamente e reinstalei o fórum e o erro persiste, alguma ideia do que pode ser? A versão continua sendo a 3.1.12, e diz estar atualizada... acham que um downgrade para a 3.1.0 pode corrigir?

Re: Erro ao enviar mensagens

Enviado: 05 Fev 2018, 17:45
por Chico Gois
Acho que é sua hospedagem

Re: Erro ao enviar mensagens

Enviado: 06 Fev 2018, 18:06
por Vin
Chico Gois escreveu:
05 Fev 2018, 17:45
Acho que é sua hospedagem
Uso uma VPS Linux, e nunca tive esse problema, já foi instalado outros fóruns com o mesmo apache e mesmo php, só agora que tá dando, mudei da versão 3.1.12 para 3.1.5 e continua o problema.

Edit: o meu php anterior era inferior ao 5.6, quando coloquei o 5.6 e instalei o fórum é que o erro veio, e não posso dar um downgrade no php por conta de aplicações na hospedagem que precisam dele.

Re: Erro ao enviar mensagens

Enviado: 06 Fev 2018, 18:26
por Vin
Bom, o erro é no arquivo ./includes/message_parser.php, na linha 84, a única coisa que tem nessa linha é

Código: Selecionar todos

					if (preg_match($regexp, $this->message))
mas não vejo nada de errado.

Um colega meu me disse que está com o mesmo problema, e usa a mesma versão do php que eu, e no mesmo bbcode ([thumbnail]), o mesmo arquivo, mesma linha, e usamos a mesma versão do phpBB.