Ícones desconfigurados. Artodia: Phantom

Suporte aos Styles/Templates para phpBB.
thetoonz
Novato
Novato
Mensagens: 41
Registrado em: 10 Jan 2014, 15:23

Ícones desconfigurados. Artodia: Phantom

Mensagem por thetoonz » 20 Jan 2014, 19:06

Qual a URL do seu fórum: Localhost
Tipo de Hospedagem: Grátis
Qual a versão do phpBB: phpBB 3.0.12
É um novo ou uma conversão: Novo
Usuário de teste: Usuário: n/d Senha: n/d
Estilos instalados: Artodia: Phantom (prosilver)
Modificações instaladas: portal / invite / mChat... entre outros
Qual seu nivel de experiência: Intermediario
Quando começou o problema: Ontem
Descreva seu problema: Adicionei os icones custom (apenas adicionei as imagens) e ficou desconfigurada, segue imagem abaixo para melhor explicar.

Eles estão assim:
Imagem

Queria eles assim:
Imagem

Já modifiquei o tamanho das imagens no imageset.cfg porém não mudou nada.
Como as imagens estão nos tamanhos certos acredito que o problema não é isso... alguem tem alguma sugestão?

Obrigado, Abraços
Editado pela última vez por thetoonz em 21 Jan 2014, 13:46, em um total de 1 vez.

Chico Gois
Administrador
Administrador
Mensagens: 3360
Registrado em: 03 Jul 2004, 03:53
Nome Real: Chico Gois
Localização: São Paulo - Capital
Contact:

Re: Ícones desconfigurados.

Mensagem por Chico Gois » 20 Jan 2014, 22:25

Atualizou pela aba template no acp?
Atenciosamente,

Chico Gois
Download da tradução: CLIQUE AQUI
Não envie MP pedindo ajuda, utilize o fórum
:: Mundo phpBB ::

thetoonz
Novato
Novato
Mensagens: 41
Registrado em: 10 Jan 2014, 15:23

Re: Ícones desconfigurados.

Mensagem por thetoonz » 20 Jan 2014, 22:33

Chico Gois escreveu:Atualizou pela aba template no acp?
Sim, atualizei... coloquei ele no online, caso queira dar uma olhada: www.testando.thetoonz.com
user: uteste
pass: 102030

Obrigado!

thetoonz
Novato
Novato
Mensagens: 41
Registrado em: 10 Jan 2014, 15:23

Re: Ícones desconfigurados.

Mensagem por thetoonz » 21 Jan 2014, 09:39

Pelo o que parece, a imagem está dentro da tabela "tópicos", junto com o link do tópico, o que preciso fazer é deixar a imagem em uma tabela separada do tópico, porém nem imagino onde se encontra essa parte do icon no html.

Alguém tem uma dica ai?

robra
Membro Sênior
Membro Sênior
Mensagens: 6065
Registrado em: 02 Dez 2010, 22:29

Re: Ícones desconfigurados.

Mensagem por robra » 21 Jan 2014, 11:38

Meu caro... fica difícil prestar suporte se você posta uma imagem do Prosilver e o Fórum está em outro estilo.
1º) Defina qual o estilo que deseja o suporte. Depois, edite sua mensagem inicial e acrescente no título o nome do estilo.
2º) Deixe o Fórum no estilo definido no 1º item.
3º) A imagem com os ícones sobrepostos é do Prosilver, enquanto que a imagem com a posição desejada dos ícones é do Subsilver2.
4º)
...nem imagino onde se encontra essa parte do icon no html.
Leia o artigo "Identificar e interagir com elementos da página" que lhe ajudará.

Abraço. Imagem
[DICA] Antes de abrir um Novo Tópico, procure saber se a sua dúvida já foi respondida. Pesquise no Google por palavras(em inglês também) relacionadas à ela, somado à palavra "phpbb".

thetoonz
Novato
Novato
Mensagens: 41
Registrado em: 10 Jan 2014, 15:23

Re: Ícones desconfigurados.

Mensagem por thetoonz » 21 Jan 2014, 13:53

robra escreveu:Meu caro... fica difícil prestar suporte se você posta uma imagem do Prosilver e o Fórum está em outro estilo.
1º) Defina qual o estilo que deseja o suporte. Depois, edite sua mensagem inicial e acrescente no título o nome do estilo.
2º) Deixe o Fórum no estilo definido no 1º item.
3º) A imagem com os ícones sobrepostos é do Prosilver, enquanto que a imagem com a posição desejada dos ícones é do Subsilver2.
4º)
...nem imagino onde se encontra essa parte do icon no html.
Leia o artigo "Identificar e interagir com elementos da página" que lhe ajudará.

Abraço. Imagem
O Style é o Artodia: Phantom, como o problema é o mesmo tando no prosilver como no Artodia: Phantom acredito que a solução é a mesma... A segunda foto é da template do meu fórum atual (www.thetoonz.com) que é baseado em Subsilver2 (só coloquei ele pra mostrar como queria que ficasse, se possivel) e nele está tudo ok, porém quero fazer isso no Artodia (baseado em prosilver)...

Quanto onde encontrar o link da imagem que disse que não sabia onde estava eu até achei, mas não sei o código que terei que fazer, está aqui:
forumlist_body.html

Código: Selecionar todos

<!-- BEGIN forumrow -->
	<!-- IF (forumrow.S_IS_CAT and not forumrow.S_FIRST_ROW) or forumrow.S_NO_CAT  -->
			</ul>

			<span class="corners-bottom"><span></span></span></div>
		</div>
	<!-- ENDIF -->

	<!-- IF forumrow.S_IS_CAT or forumrow.S_FIRST_ROW  or forumrow.S_NO_CAT  -->
		<div class="forabg">
			<div class="inner"><span class="corners-top"><span></span></span>
			<ul class="topiclist">
				<li class="header">
					<dl class="icon">
						<dt><!-- IF forumrow.S_IS_CAT --><a href="{forumrow.U_VIEWFORUM}">{forumrow.FORUM_NAME}</a><!-- ELSE -->{L_FORUM}<!-- ENDIF --></dt>
						<dd class="topics">{L_TOPICS}</dd>
						<dd class="posts">{L_POSTS}</dd>
						<dd class="lastpost"><span>{L_LAST_POST}</span></dd>
					</dl>
				</li>
			</ul>
			<ul class="topiclist forums">
	<!-- ENDIF -->

	<!-- IF not forumrow.S_IS_CAT -->
		<li class="row">
			<dl class="icon" style="background-image: url({forumrow.FORUM_FOLDER_IMG_SRC}); background-repeat: no-repeat;">
				<dt title="{forumrow.FORUM_FOLDER_IMG_ALT}">
				<!-- IF S_ENABLE_FEEDS and forumrow.S_FEED_ENABLED --><!-- <a class="feed-icon-forum" title="{L_FEED} - {forumrow.FORUM_NAME}" href="{U_FEED}?f={forumrow.FORUM_ID}"><img src="{T_THEME_PATH}/images/feed.gif" alt="{L_FEED} - {forumrow.FORUM_NAME}" /></a> --><!-- ENDIF -->

					<!-- IF forumrow.FORUM_IMAGE --><span class="forum-image">{forumrow.FORUM_IMAGE}</span><!-- ENDIF -->
					<a href="{forumrow.U_VIEWFORUM}" class="forumtitle">{forumrow.FORUM_NAME}</a><br />
					{forumrow.FORUM_DESC}
					<!-- IF forumrow.MODERATORS -->
						<br /><strong>{forumrow.L_MODERATOR_STR}:</strong> {forumrow.MODERATORS}
					<!-- ENDIF -->
					<!-- IF forumrow.SUBFORUMS and forumrow.S_LIST_SUBFORUMS --><br /><strong>{forumrow.L_SUBFORUM_STR}</strong> {forumrow.SUBFORUMS}<!-- ENDIF -->
				</dt>
				<!-- IF forumrow.CLICKS -->
					<dd class="redirect"><span>{L_REDIRECTS}: {forumrow.CLICKS}</span></dd>
				<!-- ELSEIF not forumrow.S_IS_LINK -->
					<dd class="topics">{forumrow.TOPICS} <dfn>{L_TOPICS}</dfn></dd>
					<dd class="posts">{forumrow.POSTS} <dfn>{L_POSTS}</dfn></dd>
					<dd class="lastpost"><span>
						<!-- IF forumrow.U_UNAPPROVED_TOPICS --><a href="{forumrow.U_UNAPPROVED_TOPICS}">{UNAPPROVED_IMG}</a><!-- ENDIF -->
						<!-- IF forumrow.LAST_POST_TIME --><dfn>{L_LAST_POST}</dfn> {L_POST_BY_AUTHOR} {forumrow.LAST_POSTER_FULL}
						<!-- IF not S_IS_BOT --><a href="{forumrow.U_LAST_POST}">{LAST_POST_IMG}</a> <!-- ENDIF --><br />{forumrow.LAST_POST_TIME}<!-- ELSE -->{L_NO_POSTS}<br />&nbsp;<!-- ENDIF --></span>
					</dd>
				<!-- ENDIF -->
			</dl>
		</li>
	<!-- ENDIF -->

	<!-- IF forumrow.S_LAST_ROW -->
			</ul>

			<span class="corners-bottom"><span></span></span></div>
		</div>
	<!-- ENDIF -->

<!-- BEGINELSE -->
	<div class="panel">
		<div class="inner"><span class="corners-top"><span></span></span>
		<strong>{L_NO_FORUMS}</strong>
		<span class="corners-bottom"><span></span></span></div>
	</div>
<!-- END forumrow -->
Abs
Imagem

professor mauricio
Novato
Novato
Mensagens: 130
Registrado em: 02 Abr 2011, 11:58

Re: Ícones desconfigurados. Artodia: Phantom

Mensagem por professor mauricio » 21 Jan 2014, 14:07

vou tentar traduzir do peagápês para o português:

Código: Selecionar todos

!-- IF not forumrow.S_IS_CAT -->
      <li class="row">
         <dl class="icon" style="background-image: url({forumrow.FORUM_FOLDER_IMG_SRC}); background-repeat: no-repeat;">
se na hora de rodar a tabela de fóruns o tipo não é categoria, coloca CSS do tipo lista e classe row, nessa linha, a primeira parte dela é do tipo ícone e tem uma imagem de fundo que sai da pasta de imagens do fórum, mas esse fundo não se repete...

Vc quer um ícone antes desse ícone normal? então antes dessa declaração dl class=icon vc precisa de alguma outra coisa.

o código vai ser alguma coisa assim <!-- IF forumrow.S_ICONE_NOVO --> dl class="icon" aí vem o código de onde está o ícone e fecha com <!-- ENDIF -->

sua modificação deve ter um troço assim: "procura no template por forumrow.ALGUMACOISA e coloque antes:"

se funciona em algum outro estilo, vc copia o treço de 'begin forumrow" até "endforumrow" do estilo que funfa e a gente acha uai.

acho que dá heim...

att
obrigado

thetoonz
Novato
Novato
Mensagens: 41
Registrado em: 10 Jan 2014, 15:23

Re: Ícones desconfigurados. Artodia: Phantom

Mensagem por thetoonz » 22 Jan 2014, 12:55

Ah eu dei uma solução, mas ainda não ficou da forma que eu queria, mas vlw pessoal, abraços

robra
Membro Sênior
Membro Sênior
Mensagens: 6065
Registrado em: 02 Dez 2010, 22:29

Re: Ícones desconfigurados. Artodia: Phantom

Mensagem por robra » 23 Jan 2014, 19:31

:arrow: Daria para postar uma mensagem dizendo como conseguiu resolver, compartilhando a solução com os demais usuários :?:
Depois, é só marcar com o "resolvido" a sua própria mensagem com a solução.

Abraço. Imagem
[DICA] Antes de abrir um Novo Tópico, procure saber se a sua dúvida já foi respondida. Pesquise no Google por palavras(em inglês também) relacionadas à ela, somado à palavra "phpbb".

thetoonz
Novato
Novato
Mensagens: 41
Registrado em: 10 Jan 2014, 15:23

Re: Ícones desconfigurados. Artodia: Phantom

Mensagem por thetoonz » 28 Jan 2014, 14:08

robra escreveu::arrow: Daria para postar uma mensagem dizendo como conseguiu resolver, compartilhando a solução com os demais usuários :?:
Depois, é só marcar com o "resolvido" a sua própria mensagem com a solução.

Abraço. Imagem
na verdade eu coloquei tudo dentro de uma tabela, o código ficou assim:

Código: Selecionar todos

		<table class="cat" cellpadding="0" cellspacing="0" width="100%">
	<!-- ENDIF -->
		<tr>
			<td class="forumicon">{topicrow.TOPIC_FOLDER_IMG}</td>
			<td class="forumdetails">
				<!-- IF topicrow.TOPIC_ICON_IMG --><span class="forumimage"><img src="{T_ICONS_PATH}{topicrow.TOPIC_ICON_IMG}" alt="{L_TOPIC_ICON} {L_IMAGE}" /></span><!-- ENDIF -->
				<!-- IF topicrow.S_UNREAD_TOPIC --><a href="{topicrow.U_NEWEST_POST}">{NEWEST_POST_IMG}</a> <!-- ENDIF --><a href="{topicrow.U_VIEW_TOPIC}" class="topictitle">{topicrow.TOPIC_TITLE}</a>
				<!-- IF topicrow.S_TOPIC_UNAPPROVED or topicrow.S_POSTS_UNAPPROVED --><a href="{topicrow.U_MCP_QUEUE}">{topicrow.UNAPPROVED_IMG}</a> <!-- ENDIF -->
				<!-- IF topicrow.S_TOPIC_REPORTED --><a href="{topicrow.U_MCP_REPORT}">{REPORTED_IMG}</a><!-- ENDIF --><br />
				<!-- IF topicrow.TOPIC_DESC -->{topicrow.TOPIC_DESC}<br /><!-- ENDIF -->
				<!-- IF topicrow.ATTACH_ICON_IMG -->{topicrow.ATTACH_ICON_IMG} <!-- ENDIF --><span class="forum-descriptions">{L_POST_BY_AUTHOR} {topicrow.TOPIC_AUTHOR_FULL} &raquo; {topicrow.FIRST_POST_TIME}</span>      
			</td>
        	<td class="forumtopics"><div class="statbubble"><span>{topicrow.REPLIES}</span><br />{L_REPLIES}</div></td>
            <td class="forumposts"><div class="statbubble"><span>{topicrow.VIEWS}</span><br />{L_VIEWS}</div></td>
			<td>
				{L_LAST_POST} {L_POST_BY_AUTHOR} {topicrow.LAST_POST_AUTHOR_FULL}
				<!-- IF not S_IS_BOT --><a href="{topicrow.U_LAST_POST}">{LAST_POST_IMG}</a> <!-- ENDIF --><br /><span class="fade">{topicrow.LAST_POST_TIME}</span>
			</td>
		</tr>
	<!-- IF topicrow.S_LAST_ROW -->
		</table>
Modifiquei inteiro mas deu certo... Espero que ajude alguém com o mesmo problema...

Abs

Trancado