servidor caiu [resolvido]

Suporte à dúvidas gerais relacionadas ao phpBB.
Avatar do usuário
henrique.seven2011
Moderador
Moderador
Mensagens: 716
Registrado em: 23 Mar 2012, 13:50
Nome Real: Saulo Henrique

Re: servidor caiu

Mensagem por henrique.seven2011 » 26 Mar 2016, 09:34


Avatar do usuário
niltoncavallari
Novato
Novato
Mensagens: 79
Registrado em: 09 Nov 2012, 19:37
Nome Real: nilton
Localização: São Jose dos Campos
Contact:

Re: servidor caiu

Mensagem por niltoncavallari » 26 Mar 2016, 12:06

Boas.
Ja instalei o phpbb,se eu colocar todas as pastas do meu host do pc no servidor o forum vai funcionar?
O banco de dados é o backup do qsl?se sim porque não consigo importar ele por servidor?

Avatar do usuário
niltoncavallari
Novato
Novato
Mensagens: 79
Registrado em: 09 Nov 2012, 19:37
Nome Real: nilton
Localização: São Jose dos Campos
Contact:

Re: servidor caiu

Mensagem por niltoncavallari » 31 Mar 2016, 08:07

Boas.
Pessoal, não to apressando ninguém mas estou pedindo ajuda pois meu fórum ta fora do ar,e não tenho tanto conhecimento,ja copiei o BD,primeiro e coloquei as pastas do meu host do pc no servidor não deu certo,ja instalei o phpbb certinho sem nenhum problema,e depois importei o BD,importou tudo certinho,mas deu erro,mas como to com pressa estou fazendo tudo de novo,e não to vendo qual erro.

Avatar do usuário
LucasLV
Moderador
Moderador
Mensagens: 605
Registrado em: 18 Out 2013, 04:40

Re: servidor caiu

Mensagem por LucasLV » 31 Mar 2016, 19:07

Que erro dá?
Primeiro, atualmente, você quer restaurar o fórum que vc tem rodando no EasyPHP ou tá tendo dificudades em começar do zero?

Se você tiver o BD e ele for muito grande, importe pro servidor com o BigDump

Simplesmente transfira os arquivos via FTP pro seu servidor, importe o BD no phpmyadmin do seu servidor e ao final de tudo abra o arquivo config.php e altere as informações de banco de dados de acordo com seu banco e usuários atuais

Avatar do usuário
niltoncavallari
Novato
Novato
Mensagens: 79
Registrado em: 09 Nov 2012, 19:37
Nome Real: nilton
Localização: São Jose dos Campos
Contact:

Re: servidor caiu

Mensagem por niltoncavallari » 31 Mar 2016, 21:02

Boas.
É esse o erro,ja mudei o confg.php.

General Error
SQL ERROR [ mysqli ]

Table 'nilton_cavallar.phpbb_ext' doesn't exist [1146]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.

Avatar do usuário
LucasLV
Moderador
Moderador
Mensagens: 605
Registrado em: 18 Out 2013, 04:40

Re: servidor caiu

Mensagem por LucasLV » 31 Mar 2016, 23:41

vc checou se o prefixo das tabelas é nilton_cavallar?

Por que se n for, vc tem que alterar pro que está atualmente, no config.php tbm

Quando você tiver certeza de que nada está faltando, você abre a pasta /cache e apaga todos os arquivos, menos o .htacess e index.html

Avatar do usuário
niltoncavallari
Novato
Novato
Mensagens: 79
Registrado em: 09 Nov 2012, 19:37
Nome Real: nilton
Localização: São Jose dos Campos
Contact:

Re: servidor caiu

Mensagem por niltoncavallari » 01 Abr 2016, 17:36

Boas.
Então,criei um banco de dados com o mesmo nome,nilton_cavallar,instalei o phpbb,importei o qsl,do meu fórum antigo e depois copiei as pastas do meu fórum para o servidor e comfigurei o config.php com os dados do servidor e o login e a senha.

Avatar do usuário
LucasLV
Moderador
Moderador
Mensagens: 605
Registrado em: 18 Out 2013, 04:40

Re: servidor caiu

Mensagem por LucasLV » 01 Abr 2016, 17:51

E deu certo?

Se você tem os arquivos e o BD do fórum antigo, não precisa instalar um novo phpbb3 pra depois substituir arquivos ou importar o banco. Simplesmente envie os arquivos e importe a BD e mude o config.php

Avatar do usuário
niltoncavallari
Novato
Novato
Mensagens: 79
Registrado em: 09 Nov 2012, 19:37
Nome Real: nilton
Localização: São Jose dos Campos
Contact:

Re: servidor caiu

Mensagem por niltoncavallari » 01 Abr 2016, 20:29

Boas.
Ta dando esse codigo.


Warning: require(./includes/db/phpbb\db\driver\mysqli.php): failed to open stream: No such file or directory in /var/www/html/juniorautomaticos.com.br/web/common.php on line 94

Fatal error: require(): Failed opening required './includes/db/phpbb\db\driver\mysqli.php' (include_path='.:/usr/share/pear') in /var/www/html/juniorautomaticos.com.br/web/common.php on line 94

Essa é a linha94:

require($phpbb_root_path . 'includes/db/' . $dbms . '.' . $phpEx);

Avatar do usuário
niltoncavallari
Novato
Novato
Mensagens: 79
Registrado em: 09 Nov 2012, 19:37
Nome Real: nilton
Localização: São Jose dos Campos
Contact:

Re: servidor caiu

Mensagem por niltoncavallari » 01 Abr 2016, 20:58

Boas.
Deu serto,modifiquei essa linha no confg.php.

$dbms = 'phpbb\\db\\driver\\mysqli';

Para:

$dbms = 'mysqli';

Foi resolvido,agora onde ta esse botão amarelo,como resolvido o tópico,não ta aparecendo pra min,ou não tou vendo mesmo,desde ja muito obrigado.

Trancado